GHSA-86pc-6mm8-542r

Suggest an improvement
Source
https://github.com/advisories/GHSA-86pc-6mm8-542r
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-86pc-6mm8-542r/GHSA-86pc-6mm8-542r.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-86pc-6mm8-542r
Aliases
Published
2022-05-24T17:00:28Z
Modified
2024-02-16T08:02:47.570157Z
Severity
  • 4.8 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Magento 2 Community Edition XSS Vulnerability
Details

A stored cross-site scripting (XSS) vulnerability exists in Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated admin user can inject arbitrary JavaScript code when creating a content page via page builder.

As per the Magento Release 2.3.3, if you have already implemented the pre-release version of this patch (2.3.2-p1), it is highly recommended to promptly upgrade to 2.3.2-p2.

References

Affected packages

Packagist / magento/community-edition

Package

Name
magento/community-edition
Purl
pkg:composer/magento/community-edition

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.3.0
Fixed
2.3.2-p2

Affected versions

2.*

2.3.0
2.3.1
2.3.2