GHSA-8hcf-2m4v-f2rq

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/01/GHSA-8hcf-2m4v-f2rq/GHSA-8hcf-2m4v-f2rq.json
Aliases
  • CVE-2016-15020
Published
2023-01-16T12:30:18Z
Modified
2023-01-31T02:33:47.730425Z
Details

A vulnerability was found in liftkit database up to 2.13.1. It has been classified as critical. This affects the function processOrderBy of the file src/Query/Query.php. The manipulation leads to sql injection. Upgrading to version 2.13.2 is able to address this issue. The name of the patch is 42ec8f2b22e0b0b98fb5b4444ed451c1b21d125a. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-218391.

References

Affected packages

Packagist / liftkit/database

liftkit/database

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
2.13.2

Affected versions

v1.*

v1.0
v1.0.1
v1.1.0-alpha

v2.*

v2.0.0
v2.1.0
v2.1.1
v2.10.0
v2.10.0-alpha
v2.11.0
v2.11.1
v2.11.2
v2.12.0
v2.13.0
v2.13.1
v2.2.0
v2.3.0
v2.3.1
v2.3.2
v2.3.3
v2.3.4
v2.4.0
v2.4.1
v2.4.2
v2.5.0
v2.5.1
v2.6.0
v2.6.1
v2.6.2
v2.6.3
v2.6.4
v2.6.5
v2.7.0
v2.7.1
v2.8.0
v2.9.0
v2.9.0-alpha.1
v2.9.0-alpha.2
v2.9.0-alpha10
v2.9.0-alpha3
v2.9.0-alpha4
v2.9.0-alpha5
v2.9.0-alpha6
v2.9.0-alpha7
v2.9.0-alpha8
v2.9.0-alpha9