GHSA-8jxq-gpmr-h4g4

Suggest an improvement
Source
https://github.com/advisories/GHSA-8jxq-gpmr-h4g4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-8jxq-gpmr-h4g4/GHSA-8jxq-gpmr-h4g4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-8jxq-gpmr-h4g4
Aliases
Published
2022-05-17T02:54:03Z
Modified
2024-04-25T21:12:10.838196Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
imdbphp Cross-Site Scripting (XSS)
Details

A Cross-Site Scripting (XSS) was discovered in imdbphp 5.1.1. The vulnerability exists due to insufficient filtration of user-supplied data (name) passed to the "imdbphp-master/demo/search.php" URL. An attacker could execute arbitrary HTML and script code in a browser in the context of the vulnerable website.

References

Affected packages

Packagist / imdbphp/imdbphp

Package

Name
imdbphp/imdbphp
Purl
pkg:composer/imdbphp/imdbphp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
5.2.0

Affected versions

2.*

2.2.4
2.3.0
2.3.1
2.3.2
2.3.3

v2.*

v2.3.4
v2.3.5
v2.3.6
v2.4.0
v2.4.1
v2.5
v2.6.0
v2.6.1

v3.*

v3.0.0
v3.0.1
v3.0.2
v3.1.0
v3.1.1
v3.1.2
v3.1.4
v3.1.5
v3.2.0
v3.3.0

v4.*

v4.0.0
v4.0.1
v4.1.0
v4.1.1

v5.*

v5.0.0
v5.0.1
v5.0.2
v5.0.3
v5.1.0
v5.1.1

Database specific

{
    "last_known_affected_version_range": "<= 5.1.1"
}