GHSA-8q2m-pwxf-jc7g

Suggest an improvement
Source
https://github.com/advisories/GHSA-8q2m-pwxf-jc7g
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-8q2m-pwxf-jc7g/GHSA-8q2m-pwxf-jc7g.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-8q2m-pwxf-jc7g
Aliases
Published
2022-05-17T00:55:33Z
Modified
2024-02-16T08:03:52.939136Z
Severity
  • 2.9 (Low) CVSS_V3 - CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
python-keystoneclient unsecure user password update
Details

The user-password-update command in python-keystoneclient before 0.2.4 accepts the new password in the --password argument, which allows local users to obtain sensitive information by listing the process.

References

Affected packages

PyPI / python-keystoneclient

Package

Name
python-keystoneclient
View open source insights on deps.dev
Purl
pkg:pypi/python-keystoneclient

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.2.4

Affected versions

0.*

0.1.1
0.1.2
0.1.3
0.2.0
0.2.1
0.2.2
0.2.3