GHSA-8rfc-v3vj-j62w

Suggest an improvement
Source
https://github.com/advisories/GHSA-8rfc-v3vj-j62w
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-8rfc-v3vj-j62w/GHSA-8rfc-v3vj-j62w.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-8rfc-v3vj-j62w
Aliases
Published
2022-05-24T17:03:49Z
Modified
2023-11-08T04:01:19.810730Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Jenkins Alauda DevOps Pipeline Plugin allows attackers with Overall/Read permission to capture credentials stored in Jenkins
Details

A missing permission check in Jenkins Alauda DevOps Pipeline Plugin 2.3.2 and earlier allows attackers with Overall/Read permission to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

References

Affected packages

Maven / com.alauda.jenkins.plugins:alauda-devops-pipeline

Package

Name
com.alauda.jenkins.plugins:alauda-devops-pipeline
View open source insights on deps.dev
Purl
pkg:maven/com.alauda.jenkins.plugins/alauda-devops-pipeline

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
2.3.2

Affected versions

1.*

1.0.0
1.0.1
1.0.2
1.0.3
1.0.4
1.0.5
1.0.6

2.*

2.0.1
2.0.2
2.0.3
2.3.1
2.3.2