GHSA-923w-9p3x-hmgw

Suggest an improvement
Source
https://github.com/advisories/GHSA-923w-9p3x-hmgw
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-923w-9p3x-hmgw/GHSA-923w-9p3x-hmgw.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-923w-9p3x-hmgw
Aliases
Published
2022-05-24T16:43:53Z
Modified
2024-02-16T08:07:08.149885Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Jenkins GitLab Plugin missing permission checks
Details

Jenkins GitLab Plugin did not perform permission checks on a method implementing form validation. This allowed users with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Additionally, this form validation method did not require POST requests, resulting in a cross-site request forgery vulnerability.

This form validation method now requires POST requests and Overall/Administer permissions.

References

Affected packages

Maven / org.jenkins-ci.plugins:gitlab-plugin

Package

Name
org.jenkins-ci.plugins:gitlab-plugin
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/gitlab-plugin

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.12

Affected versions

1.*

1.0.7
1.0.9
1.0.10
1.0.11
1.1.0
1.1.1
1.1.2
1.1.3
1.1.6
1.1.7
1.1.9
1.1.10
1.1.12
1.1.13
1.1.14
1.1.15
1.1.16
1.1.17
1.1.18
1.1.19
1.1.20
1.1.21
1.1.22
1.1.23
1.1.24
1.1.25
1.1.26
1.1.27
1.1.28
1.1.29
1.1.31
1.1.32
1.2.0
1.2.1
1.2.2
1.2.3
1.2.4
1.2.5
1.3.0
1.3.1
1.3.2
1.4.0
1.4.1
1.4.2
1.4.3
1.4.4
1.4.5
1.4.6
1.4.7
1.4.8
1.5.0
1.5.1
1.5.2
1.5.3
1.5.4
1.5.5
1.5.6
1.5.7
1.5.8
1.5.9
1.5.10
1.5.11

Database specific

{
    "last_known_affected_version_range": "<= 1.5.11"
}