GHSA-92ph-xm9v-cg3j

Suggest an improvement
Source
https://github.com/advisories/GHSA-92ph-xm9v-cg3j
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-92ph-xm9v-cg3j/GHSA-92ph-xm9v-cg3j.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-92ph-xm9v-cg3j
Aliases
Published
2022-05-24T17:00:24Z
Modified
2024-05-19T02:24:43.027105Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Magento Broken authentication and session managememt
Details

Insecure authentication and session management vulnerability exists in Magento 2.2 prior to 2.2.10, Magento 2.3 prior to 2.3.3 or 2.3.2-p1. An authenticated user can manipulate session validation setting for a storefront that leads to insecure authentication and session management.

References

Affected packages

Packagist / magento/community-edition

Package

Name
magento/community-edition
Purl
pkg:composer/magento/community-edition

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.2
Fixed
2.2.10

Affected versions

2.*

2.2.0
2.2.1
2.2.2
2.2.3
2.2.4
2.2.5
2.2.6
2.2.7
2.2.8
2.2.9

Packagist / magento/community-edition

Package

Name
magento/community-edition
Purl
pkg:composer/magento/community-edition

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.3
Fixed
2.3.2-p2

Affected versions

2.*

2.3.0
2.3.1
2.3.2