GHSA-92r3-p8c2-3fpx

Suggest an improvement
Source
https://github.com/advisories/GHSA-92r3-p8c2-3fpx
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/11/GHSA-92r3-p8c2-3fpx/GHSA-92r3-p8c2-3fpx.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-92r3-p8c2-3fpx
Aliases
Published
2026-11-06T18:09:45Z
Modified
2026-11-06T18:15:04Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Eclipse hawkBit DDI has Privilege Escalation that allows Tenant-Isolated Firmware Exfiltration
Details

Description

A privilege escalation vulnerability has been identified in the Direct Device Integration (DDI) Controller of Eclipse hawkBit (versions 1.0.3 and prior).

This vulnerability allows an authenticated device to escalate its permissions and bypass the strict boundaries of its assigned updates. Under normal operation, a device should be restricted strictly to the specific firmware artifacts explicitly assigned to it. However, this flaw enables any authenticated device to bypass this restriction and download any firmware artifact within the same tenant.

This is not an authentication bypass; the requesting device must possess valid credentials for its respective tenant. Instead, the issue stems from a flaw in object-level authorization validation.

A related, lower-severity helper issue exists in the listing software modules artifacts metadata endpoint. This endpoint does not enforce assignment checks, enabling an authenticated device to list and enumerate available firmware artifacts, which can facilitate targeted exfiltration using the main download authorization bypass.


Impact

  • Severity: Moderate
  • Scope: Tenant-isolated. An attacker must be an authenticated device within the target tenant to exploit this vulnerability.
  • Confidentiality Impact: Low. While firmware binaries can be retrieved, the impact is mitigated because access is restricted strictly to the scope of the pre-authenticated tenant, and no administrative or cross-tenant data is exposed. Additionally, production firmware binaries are by design not expected to contain highly sensitive or confidential data (such as hardcoded credentials or private keys), further supporting the Low confidentiality rating.

Affected Products and Versions

  • Product: eclipse-hawkbit/hawkbit
  • Affected Component: hawkbit-ddi/hawkbit-ddi-resource, as well as the compiled binaries and Docker images that contain this component.
  • Affected Versions: 1.0.3 and prior versions.
  • Patched Version: 1.0.4

Remediation

Upgrade to version 1.0.4 or later.

Fix details: The download authorization logic has been corrected to ensure that assignment-based verification is executed on every artifact download request. Additionally, the software module metadata endpoint has been updated to enforce proper authorization, restricting access exclusively to software modules and artifacts that are explicitly assigned to or already installed on the requesting device.


Credits

Eclipse would like to thank Santosh Kumar Puppala (GitHub: Santoshkumarpuppala, Email: santhoshkumar7794@gmail.com) for discovering and reporting this vulnerability through coordinated disclosure.

Database specific
{
    "cwe_ids": [
        "CWE-284",
        "CWE-862"
    ],
    "github_reviewed": true,
    "github_reviewed_at": "2026-11-06T18:09:45Z",
    "nvd_published_at": null,
    "severity": "MODERATE"
}
References

Affected packages

Maven / org.eclipse.hawkbit:hawkbit-ddi-resource

Package

Name
org.eclipse.hawkbit:hawkbit-ddi-resource
View open source insights on deps.dev
Purl
pkg:maven/org.eclipse.hawkbit/hawkbit-ddi-resource

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0 Unknown introduced version / All previous versions are affected
Fixed
1.0.4

Affected versions

0.*
0.2.0M1
0.2.0M2
0.2.0M3
0.2.0M4
0.2.0M5
0.2.0M6
0.2.0M7
0.2.0M8
0.2.0M9
0.2.0
0.2.1
0.2.2
0.2.3
0.2.4
0.2.5
0.3.0M1
0.3.0M2
0.3.0M3
0.3.0M4
0.3.0M5
0.3.0M6
0.3.0M7
0.3.0M8
0.3.0M9
0.3.0
0.4.0
0.4.1
0.5.0
0.6.1
0.7.0
0.8.0
0.9.0
0.10.0
1.*
1.0
1.0.0
1.0.1
1.0.2
1.0.3

Database specific

last_known_affected_version_range
"<= 1.0.3"
source
"https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2026/11/GHSA-92r3-p8c2-3fpx/GHSA-92r3-p8c2-3fpx.json"