GHSA-92rv-mvmj-47qh

Suggest an improvement
Source
https://github.com/advisories/GHSA-92rv-mvmj-47qh
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-92rv-mvmj-47qh/GHSA-92rv-mvmj-47qh.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-92rv-mvmj-47qh
Aliases
Published
2022-05-14T03:13:13Z
Modified
2023-11-08T03:59:36.989441Z
Severity
  • 4.2 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:L/A:N CVSS Calculator
Summary
Jenkins GitHub Pull Request Builder Plugin credential capture vulnerability
Details

A exposure of sensitive information vulnerability exists in Jenkins GitHub Pull Request Builder Plugin 1.41.0 and older in GhprbGitHubAuth.java that allows attackers with Overall/Read access to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins. Additionally, these form validation methods did not require POST requests, resulting in a CSRF vulnerability. As of version 1.42.0, these form validation methods require POST requests and Overall/Administer permissions.

References

Affected packages

Maven / org.jenkins-ci.plugin:ghprb

Package

Name
org.jenkins-ci.plugin:ghprb
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugin/ghprb

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.42.0

Database specific

{
    "last_known_affected_version_range": "<= 1.41.0"
}