GHSA-9963-gmh8-vvm6

Suggest an improvement
Source
https://github.com/advisories/GHSA-9963-gmh8-vvm6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/01/GHSA-9963-gmh8-vvm6/GHSA-9963-gmh8-vvm6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9963-gmh8-vvm6
Aliases
  • CVE-2023-24456
Published
2023-01-26T21:30:18Z
Modified
2024-02-16T08:24:33.294591Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Session fixation vulnerability in Jenkins Keycloak Authentication Plugin
Details

Jenkins Keycloak Authentication Plugin 2.3.0 and earlier does not invalidate the previous session on login.

References

Affected packages

Maven / org.jenkins-ci.plugins:keycloak

Package

Name
org.jenkins-ci.plugins:keycloak
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/keycloak

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1

Affected versions

2.*

2.0.1
2.0.2
2.0.3
2.1.0
2.1.1
2.2.0
2.3.0

Database specific

{
    "last_known_affected_version_range": "<= 2.3.0"
}