GHSA-9j65-3f2q-8q2r

Suggest an improvement
Source
https://github.com/advisories/GHSA-9j65-3f2q-8q2r
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/02/GHSA-9j65-3f2q-8q2r/GHSA-9j65-3f2q-8q2r.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9j65-3f2q-8q2r
Aliases
  • CVE-2023-25762
Published
2023-02-15T15:30:41Z
Modified
2024-02-16T08:02:23.294692Z
Severity
  • 5.4 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Cross-site Scripting in Jenkins Pipeline: Build Step Plugin
Details

Jenkins Pipeline: Build Step Plugin 2.18 and earlier does not escape job names in a JavaScript expression used in the Pipeline Snippet Generator, resulting in a stored cross-site scripting (XSS) vulnerability exploitable by attackers able to control job names.

References

Affected packages

Maven / org.jenkins-ci.plugins:pipeline-build-step

Package

Name
org.jenkins-ci.plugins:pipeline-build-step
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/pipeline-build-step

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.18.1

Affected versions

2.*

2.0
2.1
2.2
2.3
2.4
2.5
2.5.1
2.6
2.7
2.8
2.9
2.10
2.11
2.12
2.13
2.13.1
2.14
2.15
2.15.1
2.15.2
2.16
2.17
2.18

Database specific

{
    "last_known_affected_version_range": "<= 2.18"
}