GHSA-9m49-vhwv-422g

Suggest an improvement
Source
https://github.com/advisories/GHSA-9m49-vhwv-422g
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-9m49-vhwv-422g/GHSA-9m49-vhwv-422g.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9m49-vhwv-422g
Aliases
Published
2022-05-14T03:46:35Z
Modified
2024-04-24T23:11:41.585135Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Smarty PHP code injection
Details

Smarty 3 before 3.1.32 is vulnerable to a PHP code injection when calling fetch() or display() functions on custom resources that does not sanitize template name.

References

Affected packages

Packagist / smarty/smarty

Package

Name
smarty/smarty
Purl
pkg:composer/smarty/smarty

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3
Fixed
3.1.32

Affected versions

v3.*

v3.1.11
v3.1.12
v3.1.13
v3.1.14
v3.1.15
v3.1.16
v3.1.17
v3.1.18
v3.1.19
v3.1.20
v3.1.21
v3.1.23
v3.1.24
v3.1.25
v3.1.26
v3.1.27
v3.1.28
v3.1.29
v3.1.30
v3.1.31