GHSA-9r4x-3534-w3f9

Suggest an improvement
Source
https://github.com/advisories/GHSA-9r4x-3534-w3f9
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-9r4x-3534-w3f9/GHSA-9r4x-3534-w3f9.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9r4x-3534-w3f9
Aliases
Published
2022-05-24T16:49:51Z
Modified
2024-04-25T21:57:35.215449Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
paypal/adaptivepayments-sdk-php vulnerable to a reflected XSS
Details

paypal/adaptivepayments-sdk-php v3.9.2 is vulnerable to a reflected XSS in the SetPaymentOptions.php resulting code execution

References

Affected packages

Packagist / paypal/adaptivepayments-sdk-php

Package

Name
paypal/adaptivepayments-sdk-php
Purl
pkg:composer/paypal/adaptivepayments-sdk-php

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
3.9.2

Affected versions

v2.*

v2.2.98
v2.3.100
v2.3.101
v2.4.103
v2.5.106
v2.6.110
v2.7.117
v2.8.117
v2.8.118

v3.*

v3.4.102
v3.5.103
v3.6.106
v3.7.106
v3.8.106
v3.8.107
v3.9.0
v3.9.1
v3.9.2