GHSA-9w49-m7xh-5r39

Suggest an improvement
Source
https://github.com/advisories/GHSA-9w49-m7xh-5r39
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/04/GHSA-9w49-m7xh-5r39/GHSA-9w49-m7xh-5r39.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9w49-m7xh-5r39
Aliases
Published
2021-04-20T16:37:56Z
Modified
2024-02-17T05:24:20.346623Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Cross-site scripting in papermerge
Details

Multiple cross-site scripting (XSS) vulnerabilities in Papermerge before 1.5.2 allow remote attackers to inject arbitrary web script or HTML via the rename, tag, upload, or create folder function. The payload can be in a folder, a tag, or a document's filename. If email consumption is configured in Papermerge, a malicious document can be sent by email and is automatically uploaded into the Papermerge web application. Therefore, no authentication is required to exploit XSS if email consumption is configured. Otherwise authentication is required.

References

Affected packages

PyPI / papermerge

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.5.2

Affected versions

1.*

1.2.0
1.3.0