GHSA-9wm7-rc47-g56m

Suggest an improvement
Source
https://github.com/advisories/GHSA-9wm7-rc47-g56m
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-9wm7-rc47-g56m/GHSA-9wm7-rc47-g56m.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9wm7-rc47-g56m
Aliases
Published
2022-05-24T17:37:26Z
Modified
2024-05-20T19:49:42Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
dhowden tag panic due to out-of-bounds read
Details

Due to improper bounds checking, a number of methods in dhowden tag before 0.0.0-20201120070457-d52dcb253c63 can trigger a panic via readAPICFrame due to attempted out-of-bounds reads. If the package is used to parse user supplied input, this may be used as a vector for a denial of service attack.

References

Affected packages

Go / github.com/dhowden/tag

Package

Name
github.com/dhowden/tag
View open source insights on deps.dev
Purl
pkg:golang/github.com/dhowden/tag

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.0.0-20201120070457-d52dcb253c63