GHSA-9wxj-37p8-49ff

Suggest an improvement
Source
https://github.com/advisories/GHSA-9wxj-37p8-49ff
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-9wxj-37p8-49ff/GHSA-9wxj-37p8-49ff.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9wxj-37p8-49ff
Aliases
Published
2022-05-24T17:15:44Z
Modified
2023-11-08T04:02:07.625631Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Diavante vue-storefront-api and storefront-api disclose stack trace
Details

In Divante vue-storefront-api through 1.11.1 and storefront-api through 1.0-rc.1, as used in VueStorefront PWA, unexpected HTTP requests lead to an exception that discloses the error stack trace, with absolute file paths and Node.js module names.

References

Affected packages

npm / storefront-api

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.0.0-rc3

npm / vue-storefront-api

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.12.0