GHSA-9x7h-ggc3-xg47

Suggest an improvement
Source
https://github.com/advisories/GHSA-9x7h-ggc3-xg47
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/05/GHSA-9x7h-ggc3-xg47/GHSA-9x7h-ggc3-xg47.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-9x7h-ggc3-xg47
Aliases
Published
2023-05-08T15:30:20Z
Modified
2023-11-08T04:12:22.228384Z
Severity
  • 5.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
imgproxy is vulnerable to Server-Side Request Forgery
Details

imgproxy prior to version 3.15.0 is vulnerable to Server-Side Request Forgery (SSRF) due to a lack of sanitization of the imageURL parameter.

References

Affected packages

Go / github.com/imgproxy/imgproxy/v3

Package

Name
github.com/imgproxy/imgproxy/v3
View open source insights on deps.dev
Purl
pkg:golang/github.com/imgproxy/imgproxy/v3

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.15.0