GHSA-c2pj-rr68-pw94

Suggest an improvement
Source
https://github.com/advisories/GHSA-c2pj-rr68-pw94
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-c2pj-rr68-pw94/GHSA-c2pj-rr68-pw94.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-c2pj-rr68-pw94
Aliases
Published
2022-07-23T00:00:15Z
Modified
2023-11-08T04:09:41.550727Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Dataease before 1.11.2 access control issue allows attackers to arbitrarily uninstall plugin
Details

An access control issue in the component /api/plugin/uninstall Dataease v1.11.1 allows attackers to arbitrarily uninstall the plugin, a right normally reserved for the administrator. Version 1.11.2 contains a patch for this issue.

References

Affected packages

Maven / io.dataease:dataease-plugin-common

Package

Name
io.dataease:dataease-plugin-common
View open source insights on deps.dev
Purl
pkg:maven/io.dataease/dataease-plugin-common

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.11.2

Affected versions

1.*

1.0
1.1
1.2
1.3
1.4
1.5
1.6
1.7
1.8.0
1.9.0
1.10.0
1.11.0
1.11.1

Database specific

{
    "last_known_affected_version_range": "<= 1.11.1"
}