GHSA-c32g-2mgr-cfq7

Suggest an improvement
Source
https://github.com/advisories/GHSA-c32g-2mgr-cfq7
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/02/GHSA-c32g-2mgr-cfq7/GHSA-c32g-2mgr-cfq7.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-c32g-2mgr-cfq7
Aliases
Published
2022-02-02T00:01:45Z
Modified
2023-11-08T04:08:29.824588Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Out-of-bounds Write in iText
Details

iText v7.1.17 was discovered to contain a stack-based buffer overflow via the component ByteBuffer.append, which allows attackers to cause a Denial of Service (DoS) via a crafted PDF file.

References

Affected packages

Maven / com.itextpdf:itext7-core

Package

Name
com.itextpdf:itext7-core
View open source insights on deps.dev
Purl
pkg:maven/com.itextpdf/itext7-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
7.1.18

Affected versions

7.*

7.0.2
7.0.3
7.0.4
7.0.5
7.0.6
7.0.7
7.0.8
7.1.0
7.1.1
7.1.2
7.1.3
7.1.4
7.1.5
7.1.6
7.1.7
7.1.8
7.1.9
7.1.10
7.1.11
7.1.12
7.1.13
7.1.14
7.1.15
7.1.16
7.1.17

Database specific

{
    "last_known_affected_version_range": "<= 7.1.17"
}