GHSA-c4c3-3cgh-vvrh

Suggest an improvement
Source
https://github.com/advisories/GHSA-c4c3-3cgh-vvrh
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-c4c3-3cgh-vvrh/GHSA-c4c3-3cgh-vvrh.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-c4c3-3cgh-vvrh
Aliases
  • CVE-2021-21674
Published
2022-05-24T19:06:36Z
Modified
2024-02-16T08:25:07.913412Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Missing permission check in Jenkins requests-plugin Plugin allows viewing pending requests
Details

Jenkins requests-plugin Plugin 2.2.6 and earlier does not perform a permission check in an HTTP endpoint.

This allows attackers with Overall/Read permission to view the list of pending requests.

Jenkins requests-plugin Plugin 2.2.7 requires Overall/Administer permission to view the list of pending requests.

The previous sentence originally stated that Overall/Read permission was newly required. This statement was incorrect and has been fixed on 2021-07-05.

References

Affected packages

Maven / org.jenkins-ci.plugins:requests

Package

Name
org.jenkins-ci.plugins:requests
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/requests

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.2.7

Affected versions

requests-2.*

requests-2.0.1
requests-2.1.0
requests-2.2

2.*

2.0.2
2.0.3
2.0.4
2.0.5
2.2.1
2.2.2
2.2.3
2.2.4
2.2.5
2.2.6

Database specific

{
    "last_known_affected_version_range": "<= 2.2.6"
}