GHSA-c6cg-73p3-973h

Suggest an improvement
Source
https://github.com/advisories/GHSA-c6cg-73p3-973h
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/11/GHSA-c6cg-73p3-973h/GHSA-c6cg-73p3-973h.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-c6cg-73p3-973h
Aliases
Published
2023-11-27T12:30:55Z
Modified
2024-02-16T08:05:23.074802Z
Summary
Apache DolphinScheduler Exposure of Sensitive Information to an Unauthorized Actor vulnerability
Details

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in Apache DolphinScheduler. This issue affects Apache DolphinScheduler: before 3.2.1.

Users are recommended to upgrade to version 3.2.1, which fixes the issue. At the time of disclosure of this advisory, this version has not yet been released. In the mean time, we recommend you make sure the logs are only available to trusted operators.

References

Affected packages

Maven / org.apache.dolphinscheduler:dolphinscheduler-api

Package

Name
org.apache.dolphinscheduler:dolphinscheduler-api
View open source insights on deps.dev
Purl
pkg:maven/org.apache.dolphinscheduler/dolphinscheduler-api

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.2.1

Affected versions

1.*

1.2.0
1.2.1
1.3.0
1.3.1
1.3.2
1.3.3
1.3.4
1.3.5
1.3.6
1.3.7
1.3.8
1.3.9

2.*

2.0.0-alpha
2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.0.9

3.*

3.0.0-alpha
3.0.0-beta-1
3.0.0-beta-2
3.0.0
3.0.1
3.0.2
3.0.3
3.0.4
3.0.5
3.0.6
3.1.0
3.1.1
3.1.2
3.1.3
3.1.4
3.1.5
3.1.6
3.1.7
3.1.8
3.1.9
3.2.0