GHSA-c6rx-gxqv-vr5j

Suggest an improvement
Source
https://github.com/advisories/GHSA-c6rx-gxqv-vr5j
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/01/GHSA-c6rx-gxqv-vr5j/GHSA-c6rx-gxqv-vr5j.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-c6rx-gxqv-vr5j
Aliases
Published
2023-01-31T06:30:26Z
Modified
2023-11-08T04:08:04.101903Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
nemo-appium vulnerable to OS Command Injection
Details

Versions of the package nemo-appium before 0.0.9 are vulnerable to Command Injection due to improper input sanitization in the 'module.exports.setup' function.

Note: In order to exploit this vulnerability appium-running 0.1.3 has to be installed as one of nemo-appium dependencies.

References

Affected packages

npm / nemo-appium

Package

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.0.9