GHSA-c96r-38gv-grp4

Suggest an improvement
Source
https://github.com/advisories/GHSA-c96r-38gv-grp4
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/07/GHSA-c96r-38gv-grp4/GHSA-c96r-38gv-grp4.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-c96r-38gv-grp4
Aliases
Published
2024-07-05T12:31:01Z
Modified
2024-07-08T19:29:48.192434Z
Severity
  • 5.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:L CVSS Calculator
  • 5.3 (Medium) CVSS_V4 - CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X CVSS Calculator
Summary
ShopXO Server-Side Request Forgery Vulnerability
Details

A vulnerability was found in ShopXO up to 6.1.0. It has been declared as critical. Affected by this vulnerability is an unknown functionality of the file extend/base/Uploader.php. The manipulation of the argument source leads to server-side request forgery. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. The associated identifier of this vulnerability is VDB-270367. NOTE: The original disclosure confuses CSRF with SSRF.

References

Affected packages

Packagist / shopxo/shopxo

Package

Name
shopxo/shopxo
Purl
pkg:composer/shopxo/shopxo

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
6.1.0

Affected versions

v1.*

v1.1.0
v1.2.0
v1.3.0
v1.4.0
v1.5.0
v1.6.0
v1.7.0
v1.8.0
v1.8.1
v1.9.0
v1.9.1
v1.9.2
v1.9.3

v2.*

v2.0.0
v2.0.1
v2.0.2
v2.0.3
v2.2.0
v2.2.1
v2.2.2
v2.2.3
v2.2.4
v2.2.5
v2.2.6
v2.2.7
v2.2.8
v2.2.9
v2.3.0
v2.3.1
v2.3.2
v2.3.3

2.*

2.1.0

v3.*

v3.0.0
v3.0.1
v3.0.2
v3.0.3

v4.*

v4.0.0

v5.*

v5.0.0

v6.*

v6.0.0
v6.1.0