GHSA-cfqj-9g2g-w7q6

Suggest an improvement
Source
https://github.com/advisories/GHSA-cfqj-9g2g-w7q6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/12/GHSA-cfqj-9g2g-w7q6/GHSA-cfqj-9g2g-w7q6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-cfqj-9g2g-w7q6
Aliases
Published
2021-12-02T17:49:14Z
Modified
2023-11-08T04:06:47.468248Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Apache JSPWiki Cross-site Scripting due to carefully crafted plugin link invocation
Details

A carefully crafted plugin link invocation could trigger an XSS vulnerability on Apache JSPWiki, related to the Denounce plugin, which could allow the attacker to execute javascript in the victim's browser and get some sensitive information about the victim. Apache JSPWiki users should upgrade to 2.11.0 or later.

References

Affected packages

Maven / org.apache.jspwiki:jspwiki-main

Package

Name
org.apache.jspwiki:jspwiki-main
View open source insights on deps.dev
Purl
pkg:maven/org.apache.jspwiki/jspwiki-main

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.11.0

Affected versions

2.*

2.11.0.M1
2.11.0.M2
2.11.0.M3
2.11.0.M4
2.11.0.M5
2.11.0.M6
2.11.0.M7
2.11.0.M8