GHSA-cmx4-p4v5-hmr5

Suggest an improvement
Source
https://github.com/advisories/GHSA-cmx4-p4v5-hmr5
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/02/GHSA-cmx4-p4v5-hmr5/GHSA-cmx4-p4v5-hmr5.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-cmx4-p4v5-hmr5
Aliases
Published
2022-02-09T00:46:46Z
Modified
2024-02-16T08:14:56.668102Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Server-side request forgery (SSRF) in Apache Batik
Details

Apache Batik is vulnerable to server-side request forgery, caused by improper input validation by the "xlink:href" attributes. By using a specially-crafted argument, an attacker could exploit this vulnerability to cause the underlying server to make arbitrary GET requests.

References

Affected packages

Maven / org.apache.xmlgraphics:batik

Package

Name
org.apache.xmlgraphics:batik
View open source insights on deps.dev
Purl
pkg:maven/org.apache.xmlgraphics/batik

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.13

Affected versions

1.*

1.9.1
1.10
1.11
1.12