GHSA-cp2p-6xh4-jmcp

Suggest an improvement
Source
https://github.com/advisories/GHSA-cp2p-6xh4-jmcp
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2023/01/GHSA-cp2p-6xh4-jmcp/GHSA-cp2p-6xh4-jmcp.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-cp2p-6xh4-jmcp
Aliases
  • CVE-2015-10009
Published
2023-01-02T18:30:27Z
Modified
2024-02-16T08:13:27.874978Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
nterchange Code Injection vulnerability
Details

A vulnerability was found in nterchange up to 4.1.0. It has been rated as critical. This issue affects the function getContent of the file app/controllers/code_caller_controller.php. The manipulation of the argument q with the input %5C%27%29;phpinfo%28%29;/* leads to code injection. The exploit has been disclosed to the public and may be used. Upgrading to version 4.1.1 is able to address this issue. The name of the patch is fba7d89176fba8fe289edd58835fe45080797d99. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217187.

References

Affected packages

Packagist / nonfiction/nterchange

Package

Name
nonfiction/nterchange
Purl
pkg:composer/nonfiction/nterchange

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.1.1

Affected versions

4.*

4.0.0