GHSA-cqhr-jqvc-qw9p

Suggest an improvement
Source
https://github.com/advisories/GHSA-cqhr-jqvc-qw9p
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/07/GHSA-cqhr-jqvc-qw9p/GHSA-cqhr-jqvc-qw9p.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-cqhr-jqvc-qw9p
Aliases
  • CVE-2016-1000273
Published
2022-07-20T01:36:35Z
Modified
2023-11-08T03:58:08.580462Z
Severity
  • 10.0 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H CVSS Calculator
Summary
Java Melody vulnerable to cross-site scripting
Details

JavaMelody is a monitoring tool for JavaEE applications. Versions prior to 1.61.0 are vulnerable to a cross-site scripting (XSS) attack. This issue was patched in version 1.61.0, and users are recommended to upgrade to the latest version. There are no known workarounds.

References

Affected packages

Maven / net.bull.javamelody:javamelody-core

Package

Name
net.bull.javamelody:javamelody-core
View open source insights on deps.dev
Purl
pkg:maven/net.bull.javamelody/javamelody-core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.61.0

Affected versions

1.*

1.8.1
1.8.2
1.9.0
1.10.0
1.11.0
1.11.1
1.12.0
1.13.0
1.14.0
1.15.0
1.16.0
1.16.1
1.17.0
1.18.0
1.19.0
1.20.0
1.21.0
1.22.0
1.23.0
1.25.0
1.26.0
1.27.0
1.28.0
1.29.0
1.29.1
1.30.0
1.31.0
1.32.0
1.32.1
1.33.0
1.34.0
1.35.0
1.36.0
1.37.0
1.38.0
1.39.0
1.40.0
1.41.0
1.42.0
1.43.0
1.44.0
1.45.0
1.46.0
1.47.0
1.48.0
1.49.0
1.50.0
1.51.0
1.52.0
1.53.0
1.54.0
1.55.0
1.56.0
1.57.0
1.58.0
1.59.0
1.60.0