GHSA-cqp7-hwm3-cfg7

Suggest an improvement
Source
https://github.com/advisories/GHSA-cqp7-hwm3-cfg7
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-cqp7-hwm3-cfg7/GHSA-cqp7-hwm3-cfg7.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-cqp7-hwm3-cfg7
Aliases
Published
2022-05-13T01:31:34Z
Modified
2024-02-16T08:09:55.204939Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
XSS vulnerability in Jenkins Warnings Next Generation Plugin
Details

A cross-site scripting vulnerability exists in Jenkins Warnings Next Generation Plugin 1.0.1 and earlier in src/main/java/io/jenkins/plugins/analysis/core/model/DetailsTableModel.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourceDetail.java, src/main/java/io/jenkins/plugins/analysis/core/model/SourcePrinter.java, src/main/java/io/jenkins/plugins/analysis/core/util/Sanitizer.java, src/main/java/io/jenkins/plugins/analysis/warnings/DuplicateCodeScanner.java that allows attackers with the ability to control warnings parser input to have Jenkins render arbitrary HTML.

References

Affected packages

Maven / io.jenkins.plugins:warnings-ng

Package

Name
io.jenkins.plugins:warnings-ng
View open source insights on deps.dev
Purl
pkg:maven/io.jenkins.plugins/warnings-ng

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.0

Affected versions

1.*

1.0.0-beta1
1.0.0-beta2
1.0.0-beta3
1.0.0-beta4
1.0.0-beta5
1.0.0-beta6
1.0.0-beta7
1.0.0-beta8
1.0.0-beta9
1.0.0-beta10
1.0.0
1.0.1

Database specific

{
    "last_known_affected_version_range": "<= 1.0.1"
}