GHSA-cr6r-6xm9-ww22

Suggest an improvement
Source
https://github.com/advisories/GHSA-cr6r-6xm9-ww22
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-cr6r-6xm9-ww22/GHSA-cr6r-6xm9-ww22.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-cr6r-6xm9-ww22
Aliases
Published
2022-05-14T01:33:07Z
Modified
2024-02-16T08:04:27.924059Z
Severity
  • 5.9 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Yii Incorrectly Implements CORS
Details

Yii 2.x through 2.0.15.1 actively converts a wildcard CORS policy into reflecting an arbitrary Origin header value, which is incompatible with the CORS security design, and could lead to CORS misconfiguration security problems.

References

Affected packages

Packagist / yiisoft/yii2

Package

Name
yiisoft/yii2
Purl
pkg:composer/yiisoft/yii2

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.0.16

Affected versions

2.*

2.0.0-alpha
2.0.0-beta
2.0.0-rc
2.0.0
2.0.1
2.0.2
2.0.3
2.0.4
2.0.5
2.0.6
2.0.7
2.0.8
2.0.9
2.0.10
2.0.11
2.0.11.1
2.0.11.2
2.0.12
2.0.12.1
2.0.12.2
2.0.13
2.0.13.1
2.0.13.2
2.0.13.3
2.0.14
2.0.14.1
2.0.14.2
2.0.15
2.0.15.1