GHSA-crf8-h2wq-2h9x

Suggest an improvement
Source
https://github.com/advisories/GHSA-crf8-h2wq-2h9x
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/09/GHSA-crf8-h2wq-2h9x/GHSA-crf8-h2wq-2h9x.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-crf8-h2wq-2h9x
Aliases
Published
2022-09-21T00:00:38Z
Modified
2024-02-16T08:24:58.038453Z
Severity
  • CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Summary
WASM3 Improper Input Validation vulnerability
Details

WASM3 v0.5.0 was discovered to contain a segmentation fault via the component op_Select_i32_srs in wasm3/source/m3_exec.h.

References

Affected packages

PyPI / pywasm3

Package

Name
pywasm3
Purl
pkg:pypi/pywasm3

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0The exact introduced commit is unknown
Last affected
0.5.0

Affected versions

0.*

0.0.1
0.0.2
0.4.8
0.4.9
0.5.0

crates.io / wasm3

Package

Name
wasm3
Purl
pkg:cargo/wasm3

Affected ranges

Type
SEMVER
Events
Introduced
0The exact introduced commit is unknown
Last affected
0.5.0