GHSA-crvq-mw2w-4cfx

Suggest an improvement
Source
https://github.com/advisories/GHSA-crvq-mw2w-4cfx
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-crvq-mw2w-4cfx/GHSA-crvq-mw2w-4cfx.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-crvq-mw2w-4cfx
Aliases
Published
2022-05-13T01:48:34Z
Modified
2024-02-16T08:16:52.077495Z
Severity
  • 8.1 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N CVSS Calculator
Summary
Jenkins Black Duck Hub Plugin allowed any user with Overall/Read to read and write its configuration
Details

An improper authorization vulnerability exists in Jenkins Black Duck Hub Plugin 3.0.3 and older in PostBuildScanDescriptor.java that allows users with Overall/Read permission to read and write the Black Duck Hub plugin configuration.

References

Affected packages

Maven / com.blackducksoftware.integration:blackduck-hub

Package

Name
com.blackducksoftware.integration:blackduck-hub
View open source insights on deps.dev
Purl
pkg:maven/com.blackducksoftware.integration/blackduck-hub

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.1.0

Affected versions

2.*

2.0.0
2.1.0
2.1.1
2.2.0
2.2.1
2.3.0
2.3.1
2.3.2
2.3.3

3.*

3.0.0
3.0.1
3.0.2
3.0.3

Database specific

{
    "last_known_affected_version_range": "<= 3.0.3"
}