GHSA-f5r8-7h4f-jr9x

Suggest an improvement
Source
https://github.com/advisories/GHSA-f5r8-7h4f-jr9x
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-f5r8-7h4f-jr9x/GHSA-f5r8-7h4f-jr9x.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-f5r8-7h4f-jr9x
Aliases
Published
2022-05-24T17:35:32Z
Modified
2024-02-16T08:05:19.069732Z
Severity
  • 8.8 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Moodle incorrect access control
Details

A vulnerability was found in Moodle where users with "Log in as" capability in a course context (typically, course managers) may gain access to some site administration capabilities by "logging in as" a System manager. This affects 3.9 to 3.9.1, 3.8 to 3.8.4, 3.7 to 3.7.7, 3.5 to 3.5.13 and earlier unsupported versions. This is fixed in 3.9.2, 3.8.5, 3.7.8 and 3.5.14.

References

Affected packages

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.9
Fixed
3.9.2

Affected versions

v3.*

v3.9.0-beta
v3.9.0-rc1
v3.9.0-rc2
v3.9.0-rc3
v3.9.0
v3.9.1

Database specific

{
    "last_known_affected_version_range": "<= 3.9.1"
}

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.8
Fixed
3.8.5

Affected versions

v3.*

v3.8.0-beta
v3.8.0-rc1
v3.8.0
v3.8.1
v3.8.2
v3.8.3
v3.8.4

Database specific

{
    "last_known_affected_version_range": "<= 3.8.4"
}

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.7
Fixed
3.7.8

Affected versions

v3.*

v3.7.0-beta
v3.7.0-rc1
v3.7.0-rc2
v3.7.0
v3.7.1
v3.7.2
v3.7.3
v3.7.4
v3.7.5
v3.7.6
v3.7.7

Database specific

{
    "last_known_affected_version_range": "<= 3.7.7"
}

Packagist / moodle/moodle

Package

Name
moodle/moodle
Purl
pkg:composer/moodle/moodle

Affected ranges

Type
ECOSYSTEM
Events
Introduced
3.5
Fixed
3.5.14

Affected versions

v3.*

v3.5.0-beta
v3.5.0-rc1
v3.5.0
v3.5.1
v3.5.2
v3.5.3
v3.5.4
v3.5.5
v3.5.6
v3.5.7
v3.5.8
v3.5.9
v3.5.10
v3.5.11
v3.5.12
v3.5.13

Database specific

{
    "last_known_affected_version_range": "<= 3.5.13"
}