GHSA-f7fq-wp2x-jc25

Suggest an improvement
Source
https://github.com/advisories/GHSA-f7fq-wp2x-jc25
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/09/GHSA-f7fq-wp2x-jc25/GHSA-f7fq-wp2x-jc25.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-f7fq-wp2x-jc25
Aliases
  • CVE-2022-41235
Published
2022-09-22T00:00:28Z
Modified
2023-11-08T04:10:28.078093Z
Severity
  • 6.5 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Jenkins WildFly Deployer Plugin vulnerable to path traversal
Details

Jenkins WildFly Deployer Plugin 1.0.2 and earlier implements functionality that allows agent processes to read arbitrary files on the Jenkins controller file system.

This vulnerability is only exploitable in Jenkins 2.318 and earlier, LTS 2.303.2 and earlier. See the LTS upgrade guide.

References

Affected packages

Maven / org.jenkins-ci.plugins:wildfly-deployer

Package

Name
org.jenkins-ci.plugins:wildfly-deployer
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/wildfly-deployer

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.0.2

Affected versions

1.*

1.0
1.0.1
1.0.2