GHSA-f8p3-q834-q9cj

Suggest an improvement
Source
https://github.com/advisories/GHSA-f8p3-q834-q9cj
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/12/GHSA-f8p3-q834-q9cj/GHSA-f8p3-q834-q9cj.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-f8p3-q834-q9cj
Aliases
Published
2022-12-26T09:30:26Z
Modified
2023-11-08T04:05:44.870024Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
php-mod/curl allows Cross-site Scripting
Details

php-mod/curl (a wrapper of the PHP cURL extension) before 2.3.2 allows XSS via the post_file_path_upload.php key parameter and the POST data to post_multidimensional.php.

References

Affected packages

Packagist / php-mod/curl

Package

Name
php-mod/curl
Purl
pkg:composer/php-mod/curl

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.2

Affected versions

1.*

1.0
1.1.1
1.1.2
1.1.3
1.1.4
1.1.5
1.2.0
1.2.1
1.3.0
1.4.0
1.5.0
1.6.0
1.6.1
1.7.0
1.7.1
1.8.0
1.9.0
1.9.1
1.9.2
1.9.3

v1.*

v1.1.0

2.*

2.0.0-alpha1
2.0.0
2.1.0
2.2.0
2.3.0
2.3.1