GHSA-f8vc-f28w-x9c9

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-f8vc-f28w-x9c9/GHSA-f8vc-f28w-x9c9.json
Aliases
  • CVE-2021-32609
Published
2022-05-24T19:17:47Z
Modified
2022-06-21T20:32:58.059328Z
Details

Apache Superset up to and including 1.1 does not sanitize titles correctly on the Explore page. This allows an attacker with Explore access to save a chart with a malicious title, injecting html (including scripts) into the page.

References

Affected packages

PyPI / apache-superset

apache-superset

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
1.2

Affected versions

0.*

0.34.0
0.34.1
0.35.1
0.35.2
0.36.0
0.37.0
0.37.1
0.37.2
0.38.0
0.38.1

1.*

1.0.0
1.0.1
1.1.0

Database specific

{
    "last_known_affected_version_range": "<= 1.1"
}