GHSA-f8w9-66fp-3jgw

Suggest an improvement
Source
https://github.com/advisories/GHSA-f8w9-66fp-3jgw
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-f8w9-66fp-3jgw/GHSA-f8w9-66fp-3jgw.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-f8w9-66fp-3jgw
Aliases
Published
2022-05-24T16:59:38Z
Modified
2024-02-20T06:01:25.629603Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Jenkins build-metrics Plugin reflected cross-site scripting vulnerability
Details

Jenkins build-metrics Plugin does not properly escape the label query parameter, resulting in a reflected cross-site scripting vulnerability.

As of publication of this advisory, there is no fix.

References

Affected packages

Maven / org.jenkins-ci.plugins:build-metrics

Package

Name
org.jenkins-ci.plugins:build-metrics
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/build-metrics

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
1.3

Affected versions

1.*

1.0
1.1
1.2
1.3