GHSA-fc92-8r77-9297

Suggest an improvement
Source
https://github.com/advisories/GHSA-fc92-8r77-9297
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-fc92-8r77-9297/GHSA-fc92-8r77-9297.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-fc92-8r77-9297
Aliases
Published
2022-05-24T17:06:22Z
Modified
2024-02-16T08:14:27.576915Z
Severity
  • 5.0 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:N CVSS Calculator
Summary
CSRF vulnerability in Health Advisor by CloudBees Plugin
Details

Health Advisor by CloudBees Plugin 3.0 and earlier does not perform permission checks in methods performing form validation. This allows users with Overall/Read access to send an email with fixed content to an attacker-specified recipient.

Additionally, these form validation methods do not require POST requests, resulting in a CSRF vulnerability.

Health Advisor by CloudBees Plugin 3.0.1 requires POST requests and Overall/Administer permission for the affected form validation methods.

References

Affected packages

Maven / org.jenkins-ci.plugins:cloudbees-jenkins-advisor

Package

Name
org.jenkins-ci.plugins:cloudbees-jenkins-advisor
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/cloudbees-jenkins-advisor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.0.1

Affected versions

1.*

1.0
1.1
1.2
1.3
1.4
1.5

2.*

2.10
2.11

3.*

3.0