GHSA-fj2w-wfgv-mwq6

Suggest an improvement
Source
https://github.com/advisories/GHSA-fj2w-wfgv-mwq6
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/01/GHSA-fj2w-wfgv-mwq6/GHSA-fj2w-wfgv-mwq6.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-fj2w-wfgv-mwq6
Aliases
Published
2022-01-21T23:21:48Z
Modified
2024-01-30T20:14:03.384795Z
Summary
Denial of service in CBOR library
Details

Impact

Due to this library's use of an inefficient algorithm, it is vulnerable to a denial of service attack when a maliciously crafted input is passed to DecodeFromBytes or other CBOR decoding mechanisms in this library.

Affected versions include versions 4.0.0 through 4.5.0.

This vulnerability was privately reported to me.

Patches

This issue has been fixed in version 4.5.1. Users should use the latest version of this library. (The latest version is not necessarily 4.5.1. Check the README for this library's repository to see the latest version's version number.)

Workarounds

Again, users should use the latest version of this library.

In the meantime, note that the inputs affected by this issue are all CBOR maps or contain CBOR maps. An input that decodes to a single CBOR object is not capable of containing a CBOR map if—

  • it begins with a byte other than 0x80 through 0xDF, or
  • it does not contain a byte in the range 0xa0 through 0xBF.

Such an input is not affected by this vulnerability and an application can choose to perform this check before passing it to a CBOR decoding mechanism.

For more information

If you have any questions or comments about this advisory: * Open an issue in the CBOR repository.

References

Affected packages

Maven / com.upokecenter:cbor

Package

Name
com.upokecenter:cbor
View open source insights on deps.dev
Purl
pkg:maven/com.upokecenter/cbor

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.0.0
Fixed
4.5.1

Affected versions

4.*

4.0.0
4.0.1
4.1.0
4.1.1
4.1.3
4.2.0
4.3.0
4.4.0
4.4.1
4.4.2
4.4.3
4.4.4
4.5