GHSA-fjw4-39pg-vf4f

Suggest an improvement
Source
https://github.com/advisories/GHSA-fjw4-39pg-vf4f
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-fjw4-39pg-vf4f/GHSA-fjw4-39pg-vf4f.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-fjw4-39pg-vf4f
Aliases
Published
2022-05-24T16:45:24Z
Modified
2023-11-08T04:00:32.092843Z
Severity
  • 4.9 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:N/I:H/A:N CVSS Calculator
Summary
Apache Karaf vulnerable to relative path traversal
Details

Apache Karaf Config service provides a install method (via service or MBean) that could be used to travel in any directory and overwrite existing file. The vulnerability is low if the Karaf process user has limited permission on the filesystem. Any Apache Karaf version before 4.2.5 is impacted. User should upgrade to Apache Karaf 4.2.5 or later.

References

Affected packages

Maven / org.apache.karaf.config:org.apache.karaf.config.core

Package

Name
org.apache.karaf.config:org.apache.karaf.config.core
View open source insights on deps.dev
Purl
pkg:maven/org.apache.karaf.config/org.apache.karaf.config.core

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
4.2.5

Affected versions

3.*

3.0.0.RC1
3.0.0
3.0.1
3.0.2
3.0.3
3.0.4
3.0.5
3.0.6
3.0.7
3.0.8
3.0.9
3.0.10

4.*

4.0.0.M1
4.0.0.M2
4.0.0.M3
4.0.0
4.0.1
4.0.2
4.0.3
4.0.4
4.0.5
4.0.6
4.0.7
4.0.8
4.0.9
4.0.10
4.1.0
4.1.1
4.1.2
4.1.3
4.1.4
4.1.5
4.1.6
4.1.7
4.2.0.M1
4.2.0.M2
4.2.0
4.2.1
4.2.2
4.2.3
4.2.4