GHSA-fph2-fwjq-prjf

Suggest an improvement
Source
https://github.com/advisories/GHSA-fph2-fwjq-prjf
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-fph2-fwjq-prjf/GHSA-fph2-fwjq-prjf.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-fph2-fwjq-prjf
Aliases
Published
2022-05-24T17:22:18Z
Modified
2024-02-16T08:01:10.528401Z
Severity
  • 4.3 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N CVSS Calculator
Summary
Users with Overall/Read access could enumerate credentials IDs in Jenkins Fortify on Demand Plugin
Details

Fortify on Demand Plugin provides a list of applicable credentials IDs to allow users configuring the plugin to select the one to use.

This functionality does not correctly check permissions in Fortify on Demand Plugin 6.0.0 and earlier, allowing any user with Overall/Read permission to get a list of valid credentials IDs. Those can be used as part of an attack to capture the credentials using another vulnerability.

An enumeration of credentials IDs in Fortify on Demand Plugin 6.0.1 now requires the appropriate permissions.

References

Affected packages

Maven / org.jenkins-ci.plugins:fortify-on-demand-uploader

Package

Name
org.jenkins-ci.plugins:fortify-on-demand-uploader
View open source insights on deps.dev
Purl
pkg:maven/org.jenkins-ci.plugins/fortify-on-demand-uploader

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
6.0.1

Affected versions

1.*

1.0
1.01
1.02
1.03
1.04
1.05
1.06
1.07
1.08
1.09
1.10

2.*

2.0.4
2.0.5
2.0.6
2.0.7
2.0.8
2.0.9

3.*

3.0.1
3.0.2
3.0.4
3.0.5
3.0.6
3.0.8
3.0.9
3.0.10
3.0.11
3.0.12

4.*

4.0.0
4.0.1

5.*

5.0.0
5.0.1

6.*

6.0.0

Database specific

{
    "last_known_affected_version_range": "<= 6.0.0"
}