GHSA-fq54-2j52-jc42

Suggest an improvement
Source
https://github.com/advisories/GHSA-fq54-2j52-jc42
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2024/07/GHSA-fq54-2j52-jc42/GHSA-fq54-2j52-jc42.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-fq54-2j52-jc42
Aliases
  • CVE-2024-39693
Published
2024-07-10T16:03:06Z
Modified
2024-07-10T21:32:34Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
  • 8.7 (High) CVSS_V4 - CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N CVSS Calculator
Summary
Next.js Denial of Service (DoS) condition
Details

Impact

A Denial of Service (DoS) condition was identified in Next.js. Exploitation of the bug can trigger a crash, affecting the availability of the server.

This vulnerability can affect all Next.js deployments on the affected versions.

Patches

This vulnerability was resolved in Next.js 13.5 and later. We recommend that users upgrade to a safe version.

Workarounds

There are no official workarounds for this vulnerability.

Credit

We'd like to thank Thai Vu of flyseccorp.com for responsible disclosure of this vulnerability.

References

Affected packages

npm / next

Package

Affected ranges

Type
SEMVER
Events
Introduced
13.4.0
Fixed
13.5.0