GHSA-frpw-jrwx-hcfv

Suggest an improvement
Source
https://github.com/advisories/GHSA-frpw-jrwx-hcfv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/04/GHSA-frpw-jrwx-hcfv/GHSA-frpw-jrwx-hcfv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-frpw-jrwx-hcfv
Aliases
  • CVE-2021-25864
Published
2021-04-13T15:30:00Z
Modified
2023-11-08T04:05:16.433079Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N CVSS Calculator
Summary
Path Traversal in node-red-contrib-huemagic
Details

node-red-contrib-huemagic 3.0.0 is affected by hue/assets/..%2F Directory Traversal.in the res.sendFile API, used in file hue-magic.js, to fetch an arbitrary file.

References

Affected packages

npm / node-red-contrib-huemagic

Package

Name
node-red-contrib-huemagic
View open source insights on deps.dev
Purl
pkg:npm/node-red-contrib-huemagic

Affected ranges

Type
SEMVER
Events
Introduced
0Unknown introduced version / All previous versions are affected
Last affected
3.0.0