GHSA-fv7m-wc3v-wr3w

Suggest an improvement
Source
https://github.com/advisories/GHSA-fv7m-wc3v-wr3w
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-fv7m-wc3v-wr3w/GHSA-fv7m-wc3v-wr3w.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-fv7m-wc3v-wr3w
Aliases
Published
2022-05-14T01:04:10Z
Modified
2024-02-16T08:01:50.071224Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
SimpleSAMLphp XSS Vulnerability
Details

The consentAdmin module in SimpleSAMLphp through 1.14.15 is vulnerable to a Cross-Site Scripting attack, allowing an attacker to craft links that could execute arbitrary JavaScript code on the victim's web browser.

References

Affected packages

Packagist / simplesamlphp/simplesamlphp

Package

Name
simplesamlphp/simplesamlphp
Purl
pkg:composer/simplesamlphp/simplesamlphp

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.12.0
Fixed
1.14.16

Affected versions

v1.*

v1.12.0
v1.13.0-rc1
v1.13.0-rc2
v1.13.0
v1.13.1
v1.13.2
v1.14.0-rc1
v1.14.0
v1.14.1
v1.14.2
v1.14.3
v1.14.4
v1.14.5
v1.14.6
v1.14.7
v1.14.8
v1.14.9
v1.14.10
v1.14.11
v1.14.12
v1.14.13
v1.14.14
v1.14.15