GHSA-fxwr-2vxm-cg7p

Suggest an improvement
Source
https://github.com/advisories/GHSA-fxwr-2vxm-cg7p
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-fxwr-2vxm-cg7p/GHSA-fxwr-2vxm-cg7p.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-fxwr-2vxm-cg7p
Aliases
Published
2022-05-17T03:29:51Z
Modified
2024-03-11T05:45:53.835444Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
OpenStack Object Storage (Swift) allows remote attackers to cause a denial of service
Details

OpenStack Object Storage (Swift) before 2.3.1 (Kilo), 2.4.x, and 2.5.x before 2.5.1 (Liberty) do not properly close server connections, which allows remote attackers to cause a denial of service (proxy-server resource consumption) via a series of interrupted requests to a Large Object URL.

References

Affected packages

PyPI / swift

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
2.3.1

Affected versions

1.*

1.0.2

PyPI / swift

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
2.4.0
Fixed
2.5.1