GHSA-g28x-pgr3-qqx6

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/06/GHSA-g28x-pgr3-qqx6/GHSA-g28x-pgr3-qqx6.json
Aliases
  • CVE-2022-31072
Published
2022-06-15T21:24:16Z
Modified
2022-06-17T19:47:04.110830Z
Details

Impact

Versions 4.23.0 and 4.24.0 of the octokit gem were published containing world-writeable files.

Specifically, the gem was packed with files having their permissions set to -rw-rw-rw- (i.e. 0666) instead of rw-r--r-- (i.e. 0644). This means everyone who is not the owner (Group and Public) with access to the instance where this release had been installed could modify the world-writable files from this gem.

Malicious code already present and running on your machine, separate from this package, could modify the gem’s files and change its behavior during runtime.

Patches

Workarounds

Users can use the previous version of the gem v4.22.0. Alternatively, users can modify the file permissions manually until they are able to upgrade to the latest version.

References

Affected packages

RubyGems / octokit

octokit

Affected ranges

Type
ECOSYSTEM
Events
Introduced
4.23.0
Fixed
4.25.0

Affected versions

4.*

4.23.0
4.24.0