GHSA-g45g-g52h-39rg

Suggest an improvement
Source
https://github.com/advisories/GHSA-g45g-g52h-39rg
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2019/06/GHSA-g45g-g52h-39rg/GHSA-g45g-g52h-39rg.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-g45g-g52h-39rg
Aliases
Published
2019-06-07T20:56:42Z
Modified
2023-11-08T04:01:06.006878Z
Severity
  • 4.7 (Medium) CVSS_V3 - CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
Cross-site Scripting in Chartkick
Details

The Chartkick gem through 3.1.0 for Ruby allows XSS.

References

Affected packages

RubyGems / chartkick

Package

Name
chartkick
Purl
pkg:gem/chartkick

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
3.2.0

Affected versions

0.*

0.0.1
0.0.2
0.0.3
0.0.4
0.0.5

1.*

1.0.0
1.0.1
1.1.0
1.1.1
1.1.2
1.1.3
1.2.0
1.2.1
1.2.2
1.2.3
1.2.4
1.2.5
1.3.0
1.3.1
1.3.2
1.4.0
1.4.1
1.4.2
1.5.0
1.5.1
1.5.2

2.*

2.0.0
2.0.1
2.0.2
2.1.0
2.1.1
2.1.2
2.1.3
2.2.0
2.2.1
2.2.2
2.2.3
2.2.4
2.2.5
2.3.0
2.3.1
2.3.2
2.3.3
2.3.4
2.3.5

3.*

3.0.0
3.0.1
3.0.2
3.1.0