GHSA-g475-pch5-6wvv

Suggest an improvement
Source
https://github.com/advisories/GHSA-g475-pch5-6wvv
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/05/GHSA-g475-pch5-6wvv/GHSA-g475-pch5-6wvv.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-g475-pch5-6wvv
Aliases
Published
2021-05-06T18:54:35Z
Modified
2023-11-08T04:03:56.383005Z
Severity
  • 9.8 (Critical) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H CVSS Calculator
Summary
Authentication bypass in MAGMI
Details

MAGMI versions prior to 0.7.24 are vulnerable to a remote authentication bypass due to allowing default credentials in the event there is a database connection failure. A remote attacker can trigger this connection failure if the Mysql setting max_connections (default 151) is lower than Apache (or another web server) setting MaxRequestWorkers (formerly MaxClients) (default 256). This can be done by sending at least 151 simultaneous requests to the Magento website to trigger a "Too many connections" error, then use default magmi:magmi basic authentication to remotely bypass authentication.

References

Affected packages

Packagist / dweeves/magmi

Package

Name
dweeves/magmi
Purl
pkg:composer/dweeves/magmi

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
0.7.24

Affected versions

0.*

0.7.19a
0.7.19
0.7.20
0.7.21
0.7.22