GHSA-g4rw-82hq-8jpr

Suggest an improvement
Source
https://github.com/advisories/GHSA-g4rw-82hq-8jpr
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/05/GHSA-g4rw-82hq-8jpr/GHSA-g4rw-82hq-8jpr.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-g4rw-82hq-8jpr
Aliases
Published
2022-05-13T01:54:14Z
Modified
2024-02-16T08:12:07.393285Z
Severity
  • 6.1 (Medium) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N CVSS Calculator
Summary
MapProxy vulnerable to cross-site scripting in demo service
Details

MapProxy version 1.11.1 and older are vulnerable to cross-site scripting in the demo service resulting in possible information disclosure. An incomplete fix was released in v1.10.4, and a complete fix was released in v1.11.1.

References

Affected packages

PyPI / mapproxy

Package

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.11.1

Affected versions

0.*

0.8.0.dev-20100310
0.8.0.dev-20100311
0.8.0.dev-20100315
0.8.0.dev-20100322
0.8.0
0.8.1
0.8.2
0.8.3
0.8.4
0.8.4.1
0.8.5
0.9.0
0.9.0.1
0.9.1

1.*

1.0.0
1.0.1
1.1.0
1.1.1
1.1.2
1.2.0
1.2.1
1.3.0
1.4.0
1.5.0
1.6.0
1.7.0
1.7.1
1.8.0
1.8.1
1.8.2
1.9.0
1.9.1
1.10.0
1.10.1
1.10.2
1.10.3
1.10.4
1.11.0

Ecosystem specific

{
    "affected_functions": [
        "escape"
    ]
}