GHSA-g973-978j-2c3p

Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2021/07/GHSA-g973-978j-2c3p/GHSA-g973-978j-2c3p.json
Aliases
  • CVE-2021-32014
Published
2021-07-22T19:47:15Z
Modified
2022-11-22T01:00:05.894162Z
Details

SheetJS Pro through 0.16.9 allows attackers to cause a denial of service (CPU consumption) via a crafted .xlsx document that is mishandled when read by xlsx.js.

References

Affected packages

npm / xlsx

xlsx

Affected ranges

Type
SEMVER
Events
Introduced
0
Fixed
0.17.0

Affected versions

Maven / org.webjars.npm:xlsx

org.webjars.npm:xlsx

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0
Fixed
0.17.0

Affected versions

0.*

0.12.11
0.12.13
0.14.0
0.14.1
0.14.3
0.14.5
0.15.1
0.15.2
0.15.3
0.15.4
0.15.5
0.15.6
0.16.6
0.16.7
0.16.8
0.16.9
0.8.0
0.9.13