GHSA-gc67-crq6-hgh5

Suggest an improvement
Source
https://github.com/advisories/GHSA-gc67-crq6-hgh5
Import Source
https://github.com/github/advisory-database/blob/main/advisories/github-reviewed/2022/01/GHSA-gc67-crq6-hgh5/GHSA-gc67-crq6-hgh5.json
JSON Data
https://api.osv.dev/v1/vulns/GHSA-gc67-crq6-hgh5
Aliases
Published
2022-01-06T23:59:25Z
Modified
2023-11-08T04:06:59.842754Z
Severity
  • 7.5 (High) CVSS_V3 - CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H CVSS Calculator
Summary
Improper Input Validation in Parquet-MR
Details

Improper Input Validation vulnerability in Parquet-MR of Apache Parquet allows an attacker to DoS by malicious Parquet files. This issue affects Apache Parquet-MR version 1.9.0 and later versions.

References

Affected packages

Maven / org.apache.parquet:parquet

Package

Name
org.apache.parquet:parquet
View open source insights on deps.dev
Purl
pkg:maven/org.apache.parquet/parquet

Affected ranges

Type
ECOSYSTEM
Events
Introduced
1.12.0
Fixed
1.12.2

Affected versions

1.*

1.12.0
1.12.1

Maven / org.apache.parquet:parquet

Package

Name
org.apache.parquet:parquet
View open source insights on deps.dev
Purl
pkg:maven/org.apache.parquet/parquet

Affected ranges

Type
ECOSYSTEM
Events
Introduced
0Unknown introduced version / All previous versions are affected
Fixed
1.11.2

Affected versions

1.*

1.7.0
1.8.0
1.8.1
1.8.2
1.8.3
1.9.0
1.10.0
1.10.1
1.11.0
1.11.1